ForumCała strona

Nawigacja

Aktualnie online

Gości online: 3

Użytkowników online: 0

Łącznie użytkowników: 25,386
Najnowszy użytkownik: Hisfatt

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

Zbigniew@
01.04.2024 12:28:45
Wszystkiego najlepszego z okazji świąt.

JazOOn
28.02.2024 19:25:31
ja zostałem przy fusionie ale nazywa się 360. Projektowanie i druk 3d...

MajsterBieda
25.02.2024 00:12:42
Ponad 20 lat .... tosz to sioook panie.... Grin

JazOOn
24.02.2024 20:32:31
a już na pewno mamuty

JazOOn
24.02.2024 20:31:59
Albo dinozaury

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Polecamy hosting SferaHost.pl

Zobacz temat

Polski Oficjalny Support PHP-Fusion » PHP-Fusion v5.00-v6.01 Support » Instalacja
 Drukuj temat
Kodowanie polskich znaków - rozwiązanie
mat232
Jak to nie ma takiej opcji ?
 
Wścibski Gość
Dodany dnia 20.04.2024 02:41:05
Pan Kontekstualny

Postów: n^x
Data rejestracji: Zawsze

Polecamy hosting SferaHost.pl
IP: localhost  
Pieka
mat232 napisał/a:
Jak to nie ma takiej opcji ?

Po prostu nie ma takiej opcji. Po instalacji przy uzyciu oryginalnych plikow nie ma mozliwosci, aby byly "?" zamiast polskich znakow diakrytycznych. Kilka lat juz instaluje PHP-Fusion i jeszcze czegos takiego nie bylo.
To ten sam serwer co u poprzednika?
Edytowane przez Pieka dnia 12.06.2009 12:34:06
Jestem jaki jestem Smile
 
www.php-fusion.pl
mat232
Nie ja mam od kumpla co ma vpsa i ispmanager.
Edytowane przez Pieka dnia 07.08.2008 14:51:23
 
Pieka
mat232 napisał/a:
Nie ja mam od kumpla co ma vpsa i ispmanager.

To zglos sie do kumpla niech serwer poprawi i dopiero pozniej bierz sie za instalacje.
Jestem jaki jestem Smile
 
www.php-fusion.pl
jimmor
Odpowiedź od mojego providera:

Faktycznie php-fusion ma problem z polskimi znakami.

Prosze w pliku maincore.php, zaraz po:

// Establish mySQL database connection
$link = dbconnect($db_host, $db_user, $db_pass, $db_name);

dodac:

$s='SET NAMES latin2';
mysql_query($s);


Najlepiej po tej zmianie przeprowadzic instalacje od nowa, ze
zmodyfikowanym rowniez plikiem setup.php

Ponizej:

// mySQL database functions
function dbquery($query) {
$result = @mysql_query($query);

prosze dodac:
$s='SET NAMES latin2';
mysql_query($s);

Wtedy wszystko bedzie w porzadku. Nie wiem dlaczego php-fusion sie tak
zachowuje, majac baze w latin2.
 
Pieka
Pierwszy post biezacego tematu: http://www.php-fu...post_40887
Tego typu rzeczy maja miejsce podczas przenoszenia, a nie instalacji PHP-Fusion.
Edytowane przez Pieka dnia 07.08.2008 15:08:28
Jestem jaki jestem Smile
 
www.php-fusion.pl
mat232
Juz wiem czego to wina. Da sie jakos zmienic kodowanie z iso na utf 8 ?
 
Pieka
mat232 napisał/a:
Juz wiem czego to wina. Da sie jakos zmienic kodowanie z iso na utf 8 ?

Oczywiscie, ze sie da, ale kosztuje to troche pracy. Musialbys przekodowac wszystkie locale.
Prosciej bedzie zainstalowac v7 RC2, ma w standardzie locale w utf-8.

Jednak nie rozumiem jaki ma to miec cel? PHP-Fusion pracuje poprawnie na wszystkich ogolnodostepnych serwerach, bez wzgledu na kodowanie.
Jestem jaki jestem Smile
 
www.php-fusion.pl
mat232
Własnie u mnie chyba cos ISO najlepiej nie chodzi Pfft
 
vespa
Witam!
Mam poważny problem z polskimi znakami. Przeczytałem ten topik od początku ale dalej nie mogę wybrnąć z tej sytuacji. Chodzi o to, że przenosiłem stronę opartą na PHP Fusion z jednego serwera na drugi. Na tym nowym serwerze zainstalowałem jakąś z wersji 6.x (chyba najnowszą) i w panelu administracyjnym zaimportowałem bazę danych wyeksportowaną z poprzedniego serwera. Niestety nie wyświetla się większość polskich znaków.

Sprawdziłem bazę danych poprzez phpmyadmin.

System kodowania znaków dla MySQL: UTF-8 Unicode (utf8)
System porównań dla połączenia MySQL: (tu sam wybrałem) utf8_polish_ci

Jednak wchodząc do samej bazy danych, tam gdzie jest lista wszystkich tabeli etc. w kolumnie Metoda porównywania napisów przy każdej pozycji pokazuje się latin1_swedish_ci
Na samym dole, w podsumowaniu, pisane boldem jest utf8_polish_ci.

Na prawdę nie wiem co zrobić żeby pokazały się wszędzie polskie znaki. POMOCY!

EDIT: adres strony to: www.trojka-szamot...


PW od moderatora:
  1. Ogólna Uwaga - Pieka 23.08 - 18:46

Edytowane przez Pieka dnia 23.08.2008 19:26:56
 
Pieka
Sprawdziles to, co wlodekp napisal w pierwszym poscie? Dodales odpowiednia linie do maincore.php?
Jestem jaki jestem Smile
 
www.php-fusion.pl
shczurek
Witam
Przestudiowalem caly Topic zwiazany z tematem polskich znakow, probowalem juz roznych rozwiazan ale nadal mam problem z polskimi znakami, zamiast ich mam ?
Strone na ktorej mam ten problem przenosze z serwera az.pl na nazwa.pl
adres strony na ktora przenosze to smipm.nazwa.pl adres strony ktora jest przenoszona to smipm.eu. sam juz nei wiem co mam z tym zrobic.
Prosze pomozcie.
 
Pieka
shczurek napisał/a:
..Strone na ktorej mam ten problem przenosze z serwera az.pl na nazwa.pl..

W maincore.php umiescic zapis uwzgledniajacy kodowanie latin1, a nie latin2 jak zapewne uczyniles.
Jestem jaki jestem Smile
 
www.php-fusion.pl
shczurek
No fakt dorzucilam zapis latin 2 ale po zmianie na latin 1 nic sie nie zmienilo Sad
Edytowane przez Pieka dnia 26.10.2008 12:45:22
 
Pieka
shczurek napisał/a:
No fakt dorzucilam zapis latin 2 ale po zmianie na latin 1 nic sie nie zmienilo Sad

Zakladajac, ze poprawnie zaimportowales baze, po zmianie na latin1 musi byc dobrze. Testowalem wiele razy. Adres strony prosze, pozwolisz, ze sam ocenie jak to wyglada.
Jestem jaki jestem Smile
 
www.php-fusion.pl
shczurek
Adres stronki na ktorej wystepuje problem : smipm.nazwa.pl
Edytowane przez Pieka dnia 26.10.2008 12:49:22
 
Pieka
Ewidentnie brak wlasciwego wpisu w maincore.php.
Jestem jaki jestem Smile
 
www.php-fusion.pl
shczurek
Co masz na mysli mowiac brak wlasciwego wpisu ??
Jezeli idzie o ten fragment wstawiany w 46 linie:
Pobierz kod źródłowy  Rozwiń Kod źródłowy
to ten akurat mam.
Edytowane przez ICEK dnia 26.10.2008 17:44:40
 
Pieka
W takim razie masz niepoprawnie zaimportowana baze. Wykonaj to poprawnie, a strona wroci do normy.
Jestem jaki jestem Smile
 
www.php-fusion.pl
shczurek
Moja baza po eksporcie do poliku wyglada tak:
Pobierz kod źródłowy  Rozwiń Kod źródłowy MYSQL

Eksportuje ja z zaznaczeniem DROP TABLE w zgodnosci z MSSQL, w notatniku zapisuje z kodowaniem UTF8 potem import z kodowaniem latin1 i zgodnosc MSSQL i w tej chwili litery wygladaja tak :
Osoby, kt??re spowodujÂ? wypadek, mogÂ? takÂ?e uzyska?? jakieÂ? odszkodowanie?


Wpis w maincore dotyczacy kodowania mam.
Pobierz kod źródłowy  Rozwiń Kod źródłowy PHP

Juz nie wiem o co chodzi probowalem juz z importem na rozne sposoby i dalej nic.
Edytowane przez Pieka dnia 27.10.2008 10:02:52
 
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl