ForumCała strona

Nawigacja

Aktualnie online

Gości online: 2

Użytkowników online: 0

Łącznie użytkowników: 25,387
Najnowszy użytkownik: Tyka1125

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

JazOOn
14.05.2024 18:31:17
Znowu serwer down?

Zbigniew@
28.04.2024 21:33:51
Nareszcie udało się .V9 Document checking completed. No errors or warnings to show.

JazOOn
27.04.2024 21:35:25
Jazda. Udało się. Firma rusza.

Zbigniew@
01.04.2024 12:28:45
Wszystkiego najlepszego z okazji świąt.

JazOOn
28.02.2024 19:25:31
ja zostałem przy fusionie ale nazywa się 360. Projektowanie i druk 3d...

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Polecamy hosting SferaHost.pl

Zobacz temat

 Drukuj temat
Aktualizacja strony z v7.00 do v7.02
f1-mod
Witam. Chciałem zaktualizować swoją stronę z wersji 7.00 do 7.02, po wykonaniu poszczególnych kroków z instrukcji wystąpiły błędy, z którymi nie mogę sobie poradzić.
Oto jak wyglądają błędy na stronie głównej:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Prosiłbym o pomoc.

Edit: Witam. Przepraszam, że nic nie pisałem. Postanowiłem samemu jakoś to rozwiązać i problem jest już za mną, z bazą danych z błędami odzyskałem z niej to co najważniejsze i na przyszłość będę ostrożniejszy. Dziękuję.

// Błędy i wszelki kod podajemy w code. - Drecha.


PW od moderatora:
  1. Brak Stopki! - Pieka 23.04 - 23:27

Edytowane przez Pieka dnia 23.04.2011 23:26:44
 
Wścibski Gość
Dodany dnia 19.05.2024 09:52:30
Pan Kontekstualny

Postów: n^x
Data rejestracji: Zawsze

Polecamy hosting SferaHost.pl
IP: localhost  
Apis
Niestety - podpowiadana w innym wątku ( http://www.php-fu...ost_165455 ) aktualizacja wprost z wersji 7.00.xx do wersji 7.02.03 na serwerze zdalnym (nazwa.pl) nie powiodła się. Wprawdzie po uruchomieniu w PA pliku upgrade.php otrzymałem komunikat informujący o koniecznych zmianach w pliku config.php - ale po dokonaniu jej oraz po zaktualizowaniu wszystkich plików dostałem białą stronę bez żadnych komunikatów.

Taka sama aktualizacja na serwerze lokalnym (localhost) wprawdzie się powiodła, ale nie mam polskich liter.
http://www.php-fu...ost_165533
Edytowane przez Apis dnia 10.09.2011 22:35:45
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
Fasonsql
W takim razie wymuś kodowanie na latin1 lub latin2 i po problemie, polskie znaki się pojawią.
Aplikacje Windows Phone | Front-end Developer | Web-Designer
 
Apis
Próbowałem tej drogi (wymuszałem kodowanie) ale bez skutku... Za każdym razem miałem w miejsce polskich znaków diakrytycznych znaki zapytania.
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
Apis
Po wielu trudach aktualizacja wprost z wersji 7.00.xx do wersji 7.02.xx powiodła się z wykorzystaniem localhost (WebServ). Kłopot z polskimi znakami ze stron kodowanych w ISO obchodzi się instalując na localhost bazę MySQL z kodowaniem w "System porównań dla połączenia MySQL:" utf8_unicode_ci oraz "Metoda porównywania napisów" także utf8_unicode_ci. Do tak skonfigurowanej bazy importujemy tę z wersji 7.00.xx, dokonujemy upgrade według instrukcji i otrzymujemy skonwertowaną bazę, która możemy przesłać na serwer zdalny z zainstalowaną wersją 7.02.xx
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
BenLomax
Istniej może konwerter samej BD danych z PF 7.00, 7.01 do 7.02, który konwertowałby samą BD bez potrzeby ręcznego updatu?
21293.png
 
wlade
Witam,
przeprowadziłem aktualizację z wersji v7.00.1 do v7.02.06 i wszystko jest dobrze, oprócz panelu powitalnego (polskie znaki zamienione na znaki zapytania). Wchodzę w PA-> ustawienia główne i zmieniam w treści na znaki polskie, daje zapisz i wraca do do wersji ze znakami zapytania w miejscu polskich znaków.
Co jest nie tak i co muszę zrobić?

EDIT: polskie znaki cudownie "ozdrowiały". Przywróciłem kopię strony i bazy. Przełączyłem w ustawieniach głównych język na angielski i potem na polski. Następnie dokonałem ponownej instalacji i wszystko gra.
Edytowane przez wlade dnia 13.04.2013 00:00:46
 
Thor82
Przy aktualizacji strony z 7.00 na 7.02 wyskakuja mi takie komunikaty na stronie.
Pobierz kod źródłowy  Rozwiń Kod źródłowy


Co z tym można zrobić poza powrotem do starej wersji??

edit

Z częścią sobie juz poradziłem ale nadal wyskakują takie błędy.

Pobierz kod źródłowy  Rozwiń Kod źródłowy

Edytowane przez Thor82 dnia 06.05.2013 06:32:00
 
wiener-info.ugu.pl
Apis
Niemal wszystkie błędy dotyczą locale.php. Czy aby przed rozpoczęciem aktualizacji wgrałeś najpierw locale z wyższej wersji jak podpowiada readme? Jesli nie - masz błędy.
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
Thor82
Wygrałem locale przed instalacja, ale tak sobie myśle ze mogłem wygrać cały folder do folderu na serwerze (sprawdze jak wrócę do domu). Jeśli się okaże ze tak zrobiłem towystarczy wygrać te pliki prawidłowo czy przez to ze ich nie było przed aktualizacja w czymś przeszkadza?

edit


Jednak wgrałem je prawidłowo.
http://scr.hu/scr...25/mxmvqmx

Co to może być??


edit

nadpisałem wszystkie pliki "wolne" (poza katalogami) i wyskakuje teraz coś takiego

Pobierz kod źródłowy  Rozwiń Kod źródłowy

Edytowane przez Thor82 dnia 06.05.2013 19:43:15
 
wiener-info.ugu.pl
Apis
Przed aktualizacja trzeba było też powyłączać wszelkie własne modyfikacje i wtyczki (niektóre z nich na pewno nie są kompatybilne z nową wersją) oraz zmienić skórkę domyślną na Gilette. Następnie wgrać plik aktualizacyjny i locale, potem dokonać aktualizacji (nie instalacji!)
Wygrałem locale przed instalacja,

Po dokonaniu aktualizacji wgrać na serwer wszystkie pliki nowej wersji (nadpisać stare) oprócz setup.php i config.php.
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
Thor82
Korzystałem z dołączonej instrukcji czyli
Pobierz kod źródłowy  Rozwiń Kod źródłowy

a w niej nic o tym nie pisze ;/ Co mogę teraz zrobić??
 
wiener-info.ugu.pl
Apis
O wyłączeniu modyfikacji, wtyczek i skórek?
Jest o tym napisane:

Wersja 7.02 PHP-Fusion jest w dużej części kompatybilna z v7.01, jednakże wprowadzone zmiany mogą spowodować, że część wtyczek, skórek, modyfikacji czy paneli może nie działać poprawnie.

A co dopiero z wersji 7.00...

A dalej o tym co napisałem wcześniej:

W tym wydaniu wprowadzono wiele zmian w strukturze systemu, niektóre elementy Twojej strony mogą nie działać poprawnie, dopóki nie zaktualizujesz wszystkich plików. MUSISZ wgrać WSZYSTKIE pliki z katalogu /files oprócz plików:
_config.php
setup.php


Co teraz zrobić? Jeśli masz kopie wszystkich plików i bazy - przywróć poprzednią wersję. Potem wykonaj aktualizację poprawnie. Robiłem taką z wersji 7.00.xx do 7.02.xx z pominięciem 7.01.xx więc jest to możliwe.
Edytowane przez Apis dnia 07.05.2013 07:36:38
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
Thor82
Sugeruje to tylko że MOŻE nie działać poprawnie a nie że strona padnie ;( i nie ma wzmianki o wyłączeniu wtyczek. Wszystkie pliki poza config i setup oczywiście wgrałem.

Pliki mam niestety na laptopie z padniętą kartą graficzną i nie mam do nich dostępu ale kopie bazy mam na tym komputerze.
Czy to może być obojętne jaka wersja 7.00 czy musi być dokładnie taka sama (nie pamiętam jaka była dokładnie).
 
wiener-info.ugu.pl
Apis
Zainstaluj od podstaw wersję 7.00.07, potem przywróć kopię bazy danych swojej strony i zobacz czy będzie OK. Jesli nie - zainstaluj wersję niższą - np. 7.00.05. Jeśli tak - ustaw skórkę Gilette, wyłącz ewentualne własne panele, odinstaluj wtyczki i modyfikacje a następnie przystąp do aktualizacji (z pominięciem wersji 7.01.xx) zwracając uwagę na kolejność:

1. Wgraj plik update i locale
2. Przystąp w PA do procesu aktualizacji, zwracając uwagę na komunikaty
3. Jeśli aktualizacja zakończyła się pomyślnie - wgraj na serwer wszystkie pliki wersji 7.02
Edytowane przez Apis dnia 08.05.2013 06:55:43
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
www.zegluga-rzeczna.pl
ram07
Witam!
Próbowałem bezpośredniej aktualizacji z 7.00.07 do 7.02.07. Oczywiście wystąpiły problemy z kodowaniem znaków. Miałem tak podobnie przy poprzedniej aktualizacji z wersji 6 do 7. Wtedy udało mi się (przy pomocy forum) z tego wybrnąć. Teraz niestety nie. Po wielu próbach zmiany kodowania zarówno w PA jak i w bazie poprzez phpMyAdmin dodatkowo posypała się baza.
Miałem kopie ale był problem z ich wgraniem na serwer. Na szczęście pomógł administrator serwera (na serwerze robione są backupy baz).
Postanowiłem przeprowadzić nie aktualizacje lecz instalację wersji 7.02.07 z nadzieją, że przejmie informacje ze starej bazy. Instalacja się udała lecz strona jest pusta (dane bazy zostały podane i przyjęte). Co teraz mogę z tym zrobić?
 
www.sp3.wroc.pl
Pieka
Przywróć stronę z kopii i jeszcze raz zaktualizuj. Tym razem wczytaj się konkretnie w tematy dotyczące aktualizacji.
Jestem jaki jestem Smile
 
www.php-fusion.pl
ram07
Dzięki za odpowiedź. Mam przesłać kopie swoich plików (z wersji 7.00.07) na serwer i zaktualizować do najnowszej wersji (wprost lub etapami)? Wtedy wyjdą problemy z kodowaniem znaków od czego zaczęły sie moje problemy. Pliki readme przeczytałem dokładnie jak również ten wątek.
 
www.sp3.wroc.pl
Pieka
Masz przywrócić stronę (pliki + baza), najlepiej z kopii. Tak będzie najszybciej i najpewniej.
Spokojnie możesz to zrobić bezpośrednio. Pamiętaj tylko o zachowaniu tej samej wersji kodowej.
Jestem jaki jestem Smile
 
www.php-fusion.pl
ram07
Przywróciłem pliki z poprzednio działającej strony ( v.7.00.07) i bazę z kopii. Jednak brak polskich znaków tzn. brak w treści strony bo w PA są. Przestawiałem kodowanie w phpMyAdmin na kilka sposobów, dodawałem wpis w maincore.php - bez rezultatu. Albo znaki zapytania, albo jeszcze gorsze krzaczki.
 
www.sp3.wroc.pl
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl