ForumCała strona

Nawigacja

Aktualnie online

Gości online: 6

Użytkowników online: 0

Łącznie użytkowników: 25,359
Najnowszy użytkownik: kdomi

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

DJPromo
05.12.2021 13:37:54
Siemka Smile co tam słychać

JazOOn
08.11.2021 23:22:32
Widzisz a ja poszedłem w logistyke i transport Grin

Gander
07.11.2021 16:29:48
Aż się łezka w oku kręci. Wpadłem sprawdzić, od kiedy robię w PHP (rok założenia konta) Wink

JazOOn
04.11.2021 22:43:11
No ale Pieka to już tu z 5 miesięcy nie był

JazOOn
21.10.2021 22:40:48
Tak ,to ten sam JazOOn Grin

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Zobacz temat

 Drukuj temat
[EF IV] Nie mogę dodać zdjęcia do Albumu
Feniks
Witam
Od pewnego czasu nie mogę dodawać zdjęć do galerii.
Jak na ten czas mam w niej 7kategorii z czego w 4 są zdjęcia w ilości 40, 40, 34, 50.
W pozostałych 3 galeriach, są tylko NIBY zdjęcia, NIE MA ICH, zamiast miniaturki wyświetla się nazwa zdjęcia a jak klikam to nic się nie wyświetla, to tak jak by dało wpis bez zdjęcia, a w poprzednich 5 kategoriach w których wcześniej dodawałem zdjęcia teraz też nie mogę nic dodać...

Po kolei:
Wysyłam zdjęcie do zaakceptowania, w PA daję Pokaż i później "Kliknij tutaj, aby obejrzeć zdjęcie", zdjęcie działa, otwiera się w nowej zakładce, jednak gdy przyciskam "Opublikuj zdjęcie" wywala mi oto taki błąd:

Pobierz kod źródłowy  Rozwiń Kod źródłowy


Nie wiem czy to wina chmod'ów, grzebania w plikach czy czegoś innego, nie za bardzo się na tych błędach znam i nie wiem o co chodzi. Może ktoś wyjaśnić?


PW od moderatora:
  1. Zmiana nazwy tematu - Milka 22.12 - 20:18

Edytowane przez Pieka dnia 14.08.2009 16:37:33
 
Milka
Jaki CHMOD ma katalog submissions na Twoim FTP?
Sprawdź proszę, czy dane zdjęcia się w nim znajdują, a przede wszystkim zmień nazwę tematu.
Ta jedyna i prawdziwa Milka - reszta to podróbki!
 
Feniks
Katalogi photoalbum i submissions mają chmod'y 777, w submissions znajduje się tylko 1 zdjęcie i plik index.php, a w photoalbym wszystkie z albumu i jakieś pliki bez rozszerzeń o nazwach _1, _2, _3 - _9 oraz _t1 które mają 0bajtów, wydaje mi się że to są te nie działające "zdjęcia".

Co dalej?
Edytowane przez Pieka dnia 23.12.2007 00:48:12
 
Pieka
Co to za hosting? Sprawdziles, czy inne strony oparte o np. PHP-Fusion maja tam dzialajace galerie?
Jestem jaki jestem Smile
 
www.php-fusion.pl
Feniks
TAK. Wcześniej miałem darmowy ovh.org, tam zdjęcia dodawałem i tam mi przestało działać, później przeniosłem na płatny i się nie naprawiło więc to raczej nie od hostingu.

Edit:
Jakie chmod'y ustawić bo 777 dałem tak od siebie, a może galeria być full? Da się jakiś inny folder na galerie stworzyć?

Edit2:
No proszę, teraz nie działają wszystkie miniaturki i zdjęcia nie chcą się otwierać a przecież chyba tylko chmody zmieniałem... Nie działały też miniaturki kategorii ale po zmianie chmod'ów photoalbum na 777 znów się wyświetlają co niestety nie przełożyło się też na miniaturki zdjęć.
No i nie wiem dlaczego tak jest, ale gdy włączam Właściwości "miniaturki" zdjęcia, (w zasadzie jest tylko napis "Brak miniaturki" ) to pisze ścieżka

Pobierz kod źródłowy  Rozwiń Kod źródłowy


/photoalbum/album_1/1_4.jpg

Jest na FTP folder photoalbym ale nie widzę folderu albym_1 ani album_2 ani żadnego innego... Wszędzie tak jest?

Mam wgrany dodatek Ajax do wyświetlania galerii.
Link do mojego albumu:
http://www.codser...allery.php

O co chodzi??
Edytowane przez Feniks dnia 23.12.2007 10:12:41
 
bartek124
Nadpisz plik photo_functions_include.php

i powiedz co grzebałeś w plikach dot. galerii.

A tak na boku to stopki nie widzę.
userbar_bartek124_net.png mw.gif Nie pomagam na komunikatorach oraz PW!
 
www.bartek124.net
Feniks
Nadpisałem plik photo_functions_include.php z czystego fusiona i nic to nie dało.
No właśnie nie pamiętam żebym coś grzebał przy tym. Raczej nic, ale nie chce okłamywać.

STOPKA ZROBIONA Smile (można zdjąć czerwoną rangę)

Co teraz z tym albumem??
Robię stronę pół roku, będę wykupywać domenę .pl a tu takie coś. Nie będę mógł zacząć reklamy (m.in. miałem zamiar wykupić tutaj banner i link pozycjonujący) jak galeria nie będzie działać. W tę stronę włożyłem wiele pracy, a nawet pieniędzy.
Edytowane przez Feniks dnia 23.12.2007 14:55:30
 
bartek124
/administration/photoalbums.php
/administration/photos.php
/administration/settings_photo.php
/showphoto.php
/photogallery.php

Zrób sobie kopie tych plików i wgraj nowe z czystej paczki EP lub PHP-Fusion (zależy czego używasz).

Usuń wszystko z folderów photogallery (oprócz folderu submissions) i submissions.

Usuń też wszystkie albumy i zdjęcia ze poprzez stronę.


userbar_bartek124_net.png mw.gif Nie pomagam na komunikatorach oraz PW!
 
www.bartek124.net
Feniks
Podmieniłem te pliki i nic prócz tego ze ajax przestał działać i wywala błąd tam gdzie powinno być zdjęcie po kliknięciu na miniaturkę:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Ale to już pewnie od ajaxa.

Co do usuwania zdjęć i kategorii to jesteś pewny że to pomoże bo tworzona była baardzo długo i szkoda by ją niszczyć? Może najpierw znajdzie się inny sposób a to zostawmy na koniec.
Tak mi zależy żeby to działało że mogę dać dane do ftp oraz admina na stronie osobie która by to mogła sprawdzić, myślę że ułatwiło by to działanie i szybciej doszlibyśmy do naprawienia tego.
Edytowane przez Pieka dnia 23.12.2007 16:32:15
 
Pieka
Z tego, co widze wychodzi, ze zostal zmieniony tryb pracy serwera.
Nie wiem, czy Ty sam to zrobiles, czy tez jest to dzialanie administracji Twojego hostingu?!
Niczego nie usuwaj, tylko pierwsze sprawdz, czy w PHP Info w PW masz safe_mode On, czy Off.
Jesli masz z tym problem, to zapytaj admina hostingu.
Daj znac.
Jestem jaki jestem Smile
 
www.php-fusion.pl
Feniks
safe_mode jest na OFF. Powinno być na ON?
Ja raczej tego nie zmieniałem bo i chyba nie mam takiej możliwości.

Ustawienia serwa
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Edytowane przez Feniks dnia 23.12.2007 16:46:46
 
Pieka
A nie pamietasz jak bylo wczesniej?
W sumie nie musisz, bo ja wiem jak bylo...
Miales safe_mode On i zostalo zmienione na Off, czyli wylaczone.
Dlatego masz teraz problem.
Galeria szuka plikow w katalogach, a znajduja sie w katalogu glownym galerii, czyli photoalbum.

Bardziej obrazowo:
Galeria szuka: http://www.codserwis.gghost.eu/images/photoalbum/album_1/1_4.jpg
A faktycznie jest: http://www.codserwis.gghost.eu/images/photoalbum/1_4.jpg

Teraz juz rozumiesz?
Edytowane przez Pieka dnia 23.12.2007 16:53:28
Jestem jaki jestem Smile
 
www.php-fusion.pl
Feniks
heh właśnie to zauważyłem że tak jest dlatego się pytałem czy inni też tak maja.
No ale właśnie co z tym zrobić, te katalogi poznikały przez safe_mode czy co?

Tutaj daje starą stronę która stoi na serwerze z którego się przeniosłem:
http://codserwis....album_id=5

Przepraszam że nie ma stopki ale tu nie było sensu jej dodawać bo jak tylko zrobię tą galerie to usuwam stronę z tego serwera.

Tutaj galerie da się przeglądać ale już nie dodawać. Może wyłączyli safe_mode przez co dodawanie nowych stało się niemożliwe, ale przeglądać się da?
Stary serw ma takie ustawienia:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Czyli safe_mode ON

A na tym nowym to hmm, na początku dało się przeglądać a później już nie. Może to przez awarie a może chmody?
Edytowane przez Feniks dnia 23.12.2007 17:10:54
 
Pieka
Czyli to jest strona po przeniesieniu? To wszystko wyjasnia.
Na free OVH jest safe_mode On, a na nowym masz safe_mode Off, wiec masz teraz dwa wyjscia:
1. Zmienic tryb pracy serwera na safe_mode On, co jest najprostszym, ale tez i najglupszym rozwiazaniem.
2. "Powkladac" wszystkie zdjecia do katalogow, co jest najrozsadniejsze, ale tez bardzo pracochlonne Smile

Zdecydowanie polecam nr 2.
Edytowane przez Pieka dnia 23.12.2007 17:15:12
Jestem jaki jestem Smile
 
www.php-fusion.pl
Feniks
No OK ale później będę mógł dodawać nowe zdjęcia jak przeniosę lub zmienię safe_mode? Bo niby na ovh jest safe_mode ON i chodź zdjęcia da się przeglądać to już nie wiedzieć czemu nie mogę ich dodawać.
Edytowane przez Feniks dnia 23.12.2007 17:19:59
 
Pieka
Feniks napisał/a:
No OK ale później będę mógł dodawać nowe zdjęcia jak przeniosę lub zmienię safe_mode? Bo niby na ovh jest safe_mode ON i chodź zdjęcia da się przeglądać to już nie wiedzieć czemu nie mogę ich dodawać.

Oczywiscie, ze bedziesz mogl dodawac.
Na OVH mogles miec zapelniona baze i nie przyjmowala dodatkowych wpisow i/lub zmieniles chmody na katalogach galerii.
Jestem jaki jestem Smile
 
www.php-fusion.pl
Feniks
OK. Co do zapełnionej bazy na OVH to całkiem możliwe bo pamiętam że zanim się jeszcze z niego przenosiłem to baza była full, na nowym nie jest.

Znów na nowym gdy tworzę nową kategorie to zdjęcia da się dodawać i wyświetlają się dla nich miniatury, ale gdy zrobiłem katalog album_1 na FTP w photoalbum i wrzuciłem do niego np. jakieś zdjęcie to da się go wyświetlić, działa powiększenie ale nie działa mu miniaturka.
Co w takim razie zrobić aby ona też była?
Edytowane przez Feniks dnia 23.12.2007 17:52:47
 
Pieka
Feniks napisał/a:
..Znów na nowym gdy tworzę nową kategorie to zdjęcia da się dodawać i wyświetlają się dla nich miniatury, ale gdy zrobiłem katalog album_1 na FTP w photoalbum i wrzuciłem do niego np. jakieś zdjęcie to da się go wyświetlić, działa powiększenie ale nie działa mu miniaturka.
Co w takim razie zrobić aby ona też była?

Dodac ja do tego katalogu Smile
Edytowane przez Pieka dnia 23.12.2007 17:55:32
Jestem jaki jestem Smile
 
www.php-fusion.pl
Feniks
hmm no a skąd mam wiedzieć jak ona się nazywa bo na stronie nie mogę znaleźć do niej odnośnika. Mam wszystkie zdjęcia porównywać i wrzucać do odpowiednich albumów?
No, a co by się stało jak bym zmieniał safe_mode na ON? Trzeba by było przenosić zdjęcia?

Edit:
OK zauważyłem na serwie że miniatury są oznaczone dopiskiem _t1 a zdjęcia _t2, więc nie było by takiego problemu.

No ale w dalszym ciągu co by dała zmiana safe_mode na ON?
Edytowane przez Feniks dnia 23.12.2007 18:01:56
 
Pieka
Feniks napisał/a:
Hmm no a skąd mam wiedzieć jak ona się nazywa bo na stronie nie mogę znaleźć do niej odnośnika. Mam wszystkie zdjęcia porównywać i wrzucać do odpowiednich albumów?
No, a co by się stało jak bym zmieniał safe_mode na ON? Trzeba by było przenosić zdjęcia?

Dlatego napisalem, ze jest to przyszlosciowo korzystne, ale bardzo pracochlonne.
Nie, po zmianie na safe_mode On mialbys wszystkie zdjecia na swoim miejscu, oczywiscie poza nowymi, ktore dodales teraz.
Edytowane przez Pieka dnia 23.12.2007 18:01:59
Jestem jaki jestem Smile
 
www.php-fusion.pl
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl