ForumCała strona

Nawigacja

Aktualnie online

Gości online: 7

Użytkowników online: 0

Łącznie użytkowników: 25,386
Najnowszy użytkownik: Hisfatt

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

JazOOn
22.02.2024 19:47:19
Mniemam że wątpie.

sferahost
22.02.2024 08:26:20
Za co bardzo przepraszam. Wynikły niespodziewane problemy z maszyną.

Zbigniew@
22.02.2024 07:43:48
Coraz dłuższe awarię na tym forum.

khaman
31.01.2024 21:56:35
Dokładnie, wszystko wina Milki Grin

piterus
31.01.2024 20:25:53
@khaman Albo taka impreza była, albo Milka porządki trzymała żelazną ręką Pfft

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Polecamy hosting SferaHost.pl

Zobacz temat

Polski Oficjalny Support PHP-Fusion » PHP-Fusion v5.00-v6.01 Support » Instalacja
 Drukuj temat
Przenoszenie strony na inny serwer
m@rkop
Pieka napisał/a:
Nie przeczytales calego tematu.... Exportujesz baze, przenosisz pliki, a nastepnie importujesz kopie bazy na nowy serwer, najlepiej wszystko (poza plikami) za pomoca phpMyAdmin'a.

Dzieki za info. Zrobileem wszystko jak napisales, tzn. baze importowalem za pomoca panelu, bo phpmyadmin niee smigal i mam problem z kodowaniem. Podczas importu przez phpmy admina pojawia sie taki blad:

Błąd:
Pobierz kod źródłowy  Rozwiń Kod źródłowy


Co robie zle?
Pzdr
Edytowane przez Pieka dnia 21.10.2009 20:18:41
 
Wścibski Gość
Dodany dnia 23.02.2024 02:06:47
Pan Kontekstualny

Postów: n^x
Data rejestracji: Zawsze

Polecamy hosting SferaHost.pl
IP: localhost  
Pieka
Usunac wpis o tworzeniu bazy, bo baze juz masz i potrzebujesz, tylko przywrocic tabele.
Jestem jaki jestem Smile
 
www.php-fusion.pl
m@rkop
Pieka napisał/a:
Usunac wpis o tworzeniu bazy, bo baze juz masz i potrzebujesz, tylko przywrocic tabele.

Sorry, ze pytam o proste rzeczy, ale gdzie mam to zrobic? Czy dobrze sie domyslam, ze chodzi o to: "Liczba rekordów (zapytań), które należy z początku pominąć"? Jesli tak, to jaka liczbe wpisac?
Pzdr
Edytowane przez m@rkop dnia 09.12.2006 16:38:05
 
Spoczywaj w pokoju... wlodekp
Skoro już masz zaimportowaną bazę. to przenosisz wszystkie pliki na nowy serwer, zmienianiasz wpisy w edycji po ftp w pliku config.php na nowe-obowiązujące na tym serwerze:
$db_host="???";
$db_user="???";
$db_pass="???";
bo pozostałe powinny być takie same po Twoim imporcie

 
wlodekp.europa.pl
m@rkop
wlodekp napisał/a:
Skoro już masz zaimportowaną bazę. to przenosisz wszystkie pliki na nowy serwer, zmienianiasz wpisy w edycji po ftp w pliku config.php na nowe-obowiązujące na tym serwerze:
$db_host="???";
$db_user="???";
$db_pass="???";
bo pozostałe powinny być takie same po Twoim imporcie

Pliki mam przeniesione, ale wlasnie nie moge zaimportowac bazy. Pojawia sie blad, ktory opisalem wyzej. Co robic?
Pzdr
 
Spoczywaj w pokoju... wlodekp
No to pisz precyzyjnie co masz bo ja czytam dokładnie:
baze importowalem za pomoca panelu,

Jaka jest dokładnie w tej chwili sytuacja z bazą-jest jakaś?-nazwa-pusta czy nie ma wcale bo jedno nieprecyzyjne słowo i nici z tego. A to dopiero pocżątek, bo zaraz się zacznie z brakiem polskich liter.
 
wlodekp.europa.pl
m@rkop
wlodekp napisał/a:
No to pisz precyzyjnie co masz bo ja czytam dokładnie:
baze importowalem za pomoca panelu,


Tak bylo wczesniej...

Jaka jest dokładnie w tej chwili sytuacja z bazą


Może po kolei:
- zainstalowalem fusiona na nowym serwerze (ma baze kodowana w latin2),
- skopiowalem wszystkie pliki ze starego serwera,
- zaimportowalem baze (kodowana w latin1) ze starego serwera, nie zmieniajac niestety kodowania w "Zestaw znaków dla pliku:" na latin2,
- na stronie pojawily sie krzaki, wiec postanowilem zaimportowac jeszcze raz baze i tym razem zmienic ten "Zestaw znaków dla pliku:",
- niestety pojawil sie blad, o ktorym pisalem wczesniej,
- usunalem wiec zaimportowana baze,
- utworzylem baze danych od nowa,
- skopiowalem na serwer plik setup.php i zainstalowalem fusiona jeszcze raz,
- probuje zaimportowac stara baze, ale niestety znowu pojawia sie ten blad.

-jest jakaś?-nazwa-pusta czy nie ma wcale bo jedno nieprecyzyjne słowo i nici z tego. A to dopiero pocżątek, bo zaraz się zacznie z brakiem polskich liter.


Mysle, ze wyzej opisalem troche dokladniej w czym problem...
Pzdr
 
Spoczywaj w pokoju... wlodekp
W tym przypadku-powinno to wyglądać tak:
Instalacja nowego fusiona z latin2-opisywałem w maincore dopiska dla wyświetlania polskich znaków-temat przyklejony-INSTALACJA rozwiązanie.
Import kopi najlepiej utworzonej z PA starego fusion-przez phpmyadmin z USUNIĘTYMI wpisami(wszystkimi):
DEFAULT CHARACTER SET latin1 COLLATE latin1_german2_ci
import-tu bez wyboru-powinien zadziałać-jeśli jednak będą krzaki to z wyborem latin2-ale tu raczej nie.
PODSTAWA TO USUNĄĆ TO LATIN1.... BO JAK NIE TO MOŻE NIE ŁYKAĆ ALBO ZNOWU TAK ZAKODUJE I W BAZIE Z LATIN2 I BĘDZIE KASZANA!!!

 
wlodekp.europa.pl
m@rkop
wlodekp napisał/a:
W tym przypadku-powinno to wyglądać tak:
Instalacja nowego fusiona z latin2-opisywałem w maincore dopiska dla wyświetlania polskich znaków-temat przyklejony-INSTALACJA rozwiązanie.
Import kopi najlepiej utworzonej z PA starego fusion-przez phpmyadmin z USUNIĘTYMI wpisami(wszystkimi):
DEFAULT CHARACTER SET latin1 COLLATE latin1_german2_ci
import-tu bez wyboru-powinien zadziałać-jeśli jednak będą krzaki to z wyborem latin2-ale tu raczej nie.
PODSTAWA TO USUNĄĆ TO LATIN1.... BO JAK NIE TO MOŻE NIE ŁYKAĆ ALBO ZNOWU TAK ZAKODUJE I W BAZIE Z LATIN2 I BĘDZIE KASZANA!!!


Dzieki za pomoc. W maincore dopisalem co trzeba, w starej bazie pousuwalem wszystkie wpisy DEFAULT CHARACTER SET latin1 (tylko takie byly, nie bylo nic z COLLATE), choc nie wiedzialem czy zostawic sredniki po tych wpisach, niestety nie moge dokonac importu, bo phpmyadmin tak sie slimaczy, ze nie sposob tego zrobic Sad
Pzdr
 
Spoczywaj w pokoju... wlodekp
Napisałem Ci o kopii z PA bo tam bez problemów możesz zrobić bazy częściowe wybierając tabele-kopia z kompresją do gz żeby mniejsza i co za problem comanderem wyciągnąć plik sgl jego modyfikować i podmienić w skompresowanym. Phpmyadmin zawsze łyknie taką baze-modyfikowaną częściową. PA nie bo zgubisz 1 znacznik i klapa.
 
wlodekp.europa.pl
m@rkop
Ufff udało się Smile Dzięki Smile
Pzdr
 
xeo
Torpedox napisał/a:
Ja przenosze to tak jak mówice, ale mam taki błąd: teksty są urwane! mozecie zbaczyć sami - stara strona: www.megaman.xt.pl, nowa: http://torpedox.n...g/news.php


Sory ale ja nie widze żadnego podobieństwa tych stron a doskwiera mi podobny problem jak myślę.

OLD-SITE >>> www.xeo.yoyo.pl <<< NEW-SITE >>> www.squad-mx.pl <<<

No i związku z tym moje pytanie co może być tego przyczyną??
-źle skopiowane pliki na serwer poprzez ftp?
-źle przeniesiona $DB? (były problemy a mianowicie przy imporcie $DB na serwer pliku sql.gz phpadmin wywala taki błąd:

Pobierz kod źródłowy  Rozwiń Kod źródłowy


a przy pliku .sql nie wyświetla części strony i w niekturych panelach są błędy.
Edytowane przez Pieka dnia 12.12.2006 20:52:58
__________________________________________
Jestem głęboko wierzącym ateistą.(Albert Einstein)
Kto wie, ile trzeba wiedzieć, aby wiedzieć, że się jeszcze wszystkiego nie wie?
 
www.mx.sq.pl
Pieka
Niewlasciwe kodowanie, a co za tym import tylko czesci bazy.
Na temat przenoszenie + kodowanie wlodekp napisal praktycznie wszystko, wiec poszukaj, tym bardziej, ze jest to temat nizej w tym dziale.
Edytowane przez Pieka dnia 12.12.2006 21:01:33
Jestem jaki jestem Smile
 
www.php-fusion.pl
xeo
xeo napisał/a:
-źle przeniesiona $DB? (były problemy a mianowicie przy imporcie $DB na serwer pliku sql.gz phpadmin wywala taki błąd:

Pobierz kod źródłowy  Rozwiń Kod źródłowy


Zrobiłem jeszcze raz kopie $DB-sql.gz z starego serwera lecz tym razem zaznaczyłem opcje w phpMyAdmin >> Dodaj DROP TABLE << i zaimportowałem na nowy serwer, są widoczne brakujące części strony lecz brak polskich znaków, oraz nie wyświetlają się fotki w galerii.:@ lecz wywala taki błąd
Pobierz kod źródłowy  Rozwiń Kod źródłowy

__________________________________________
Jestem głęboko wierzącym ateistą.(Albert Einstein)
Kto wie, ile trzeba wiedzieć, aby wiedzieć, że się jeszcze wszystkiego nie wie?
 
www.mx.sq.pl
Royal116
1. Kopiujesz wszystkie pliki Fusiona ze starego serwera.
2. Eksportujesz baze starej strony przez phpMyAdmina.
3. Umieszczasz skopiowane pliki na nowym serwerze.
4. Importujesz do uprzednio zalozonej nowej bazy, kopie starej bazy.
5. Edytujesz plik config.php i wpisujesz odpowiednie dane nowej bazy.
Odpalasz strone.

Dlaczego u mnie nie widac pliku config.php czytałem ze moze byc pod inna nazwą ale nic z tego wogole tego pliku niema. Pomocy!!
Edytowane przez Pieka dnia 16.03.2007 22:19:35
 
neoprzemek
Witam!! Ja przeniosłem na nowy serwer i mi się udało beż żadnych problemów, dlatego też może opiszę jak to zrobiłem to może przyda sie to komuś. Smile

Mój nowy serwer to www.my-place.us polecam wszystkim którzy szukają darmowego serwera pod php-fusion.Grin

Niestety phpMyAdmin na mu-place.us ma zablokowaną opcje IMPORT ale nie załamujemy sie jest na to inny sposób

No więc do dzieła:

1. Tworzymy konto na my-place.us i bazę.
2. Wgrywamy na serwer php-fuiona.
3. Teraz wchodzimy na stary serwer z naszą strona, logujemy sie jako administrator i wchodzimy kolejno w: PANEL ADMINA --> ZARZąDZANIE STRONą --> KOPIA BAZY DANYCH.
4. Robimy kopie bazy wybierając TYP KOPII:.sql nie może to być sql.gz(kompresja)
5. Gdy już mamy zrobioną kopie bazy danych i mamy ją na naszym dysku twardym kopiujemy teraz wszystkie pliki z starego serwera na dysk.
6. Gdy już mamy skopiowane pliki wgrywamy je teraz na nowy serwer.
7. Ok pliki sie wgrały musimy teraz tylko wymedytować plik config.php, (dla zielonych całkowicie wpisujemy aktualną nazwe bazy, hasło, adres i nazwe użytkownika)
8. Mamy już wy edytowany plik cinfig.php możemy odpalić naszą stronę na nowym serwerze.
9. Teraz logujemy sie jako administrator i wchodzimy kolejno w: PANEL ADMINA --> ZARZąDZANIE STRONą --> KOPIA BAZY DANYCH.
10. Teraz przywracamy wcześniej zrobioną kopie bazy danych którą may na dysku.
11. Po przywróceniu widzimy ze nasza strona wygląda identycznie jak ta na starym serwerze.
djAleX
 
www.osk-kurzawa.pl
lamborghini
ale jak sie wgywa na nowy server phpfusiona?
 
zezol
Postanowiłem postawić Fusion'a na localhoście - program jakiego używam: WebServ
Zrobiłem co trzeba, czyli wykasowałem wszystkie: "ENGINE=MyISAM DEFAULT CHARSET=latin1". Chyba jeszcze "coś" zostało, bo po imporcie bazy widzę:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

A przy próbie wejścia z poziomu przeglądarki:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Dane z config.php:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

PS: Domyślnie dostęp do bazy: login - root; hasło - nic(bez hasła)
Nie wybrałem żadnej bazy? Hmm... Może: "Database Name:" lub prefix zły...
Proszę o małą pomoc:)
Edytowane przez zezol dnia 11.04.2007 19:35:19
 
Pieka
To chyba logiczne, ze pierwsze musisz wybrac baze, a dopiero pozniej importowac plik kopii?!
Jestem jaki jestem Smile
 
www.php-fusion.pl
zezol
Przepraszam, pomyłka(akurat za tym razem nie wybrałem). To, co wyskakuje:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

A dziwne, bo wszystkie wpisy(wymienione w moim poście wyżej) usunąłem...
 
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl