ForumCała strona

Nawigacja

Aktualnie online

Gości online: 11

Użytkowników online: 0

Łącznie użytkowników: 25,386
Najnowszy użytkownik: Hisfatt

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

MajsterBieda
25.02.2024 00:12:42
Ponad 20 lat .... tosz to sioook panie.... Grin

Zbigniew@
24.02.2024 22:05:41
Jeszcze tylko, pozostało, napisać artykuł i będzie gotowe. Za jakieś dwa dni.

Zbigniew@
24.02.2024 22:03:43
A ja wstawię auto reklamę. Zrobiłem pierwszy generator paneli na stronę główna, dla v9.

JazOOn
24.02.2024 20:32:31
a już na pewno mamuty

JazOOn
24.02.2024 20:31:59
Albo dinozaury

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Polecamy hosting SferaHost.pl

Zobacz temat

 Drukuj temat
Brak tabel w bazie po instalacji Professional Download System 1.8.4
Bikobi
Po aktualizacji strony z v6 na 7 postanowiłem używać tego moda dla obsługi downloadu. Niestety, żadne próby nie dają tabel w bazie. Wiem, że brzmi to noobosko, ale, może opiszę więcej: Na początku miałem problem opisany tu: http://www.php-fu...d_id=23136 Podczas dodawania pliku wyświetla:
Status: CREATING...
W następnych krokach plik niby wysyła, zatwierdza , daje na online, ale i tak mam ten komunikat. Może to wina skórki i/lub spolszczenia? Nie. Jedyna różnica na języku angielskim strony to brak komunikatu zbieżnego z tymi w linkowanym temacie.

Instalacja standardowa, chmody poprawne. Mogę dodać plik, mogę edytować, tworzyć kategorie itd - ale na pusto, bo nie ma tabel. Nie ma też panelu bocznego. Mod widoczny w panelu admina w Wtyczki, widać, że zainstalowany, ale nie... Chmody dałem na 777, nawet dla każdego folderu wtyczki (nie tylko Downloads i Images). Nawet, w desperacji, wszystkim plikom php w katalogu pro_download_panel dałem ten 777. Nic, null. Deinstalacje wtyki nic nie dają, nie daje usuwanie foldera i ponowne wrzucanie moda na FTP, zarówno na polskiej jak i angielskiej wersji językowej.

Strona na nazwa.pl, płatna. PHP-Fusion v7.00.04 Core PL, mod w wersji 184[7.00.00]-1.0. Pomóżcie, bo nie mam już siły na to. Dotąd tak nic nie stawało mi kantem.
Edytowane przez Pieka dnia 19.02.2009 18:27:19
 
Wścibski Gość
Dodany dnia 25.02.2024 05:33:16
Pan Kontekstualny

Postów: n^x
Data rejestracji: Zawsze

Polecamy hosting SferaHost.pl
IP: localhost  
FiXik
Witam ... poprawiłem trochę panel ... podmień plik infusion.php w katalogu i stworzy ci tabele ... tylko odinstaluj i zainstaluj wtyczkę od nowa ... ale za to pojawia się parę innych problemów, w panelu administracyjnym, których na razie nie mam czasu sprawdzać. Może ktoś będzie szybszy ode mnie. Pozdrawiam
FiXik dodał/a następującą plik:
infusion.rar [2.06kB / 507 Pobrane]

Edytowane przez FiXik dnia 23.02.2009 17:03:13
 
http://www.zainwestujwemnie.eu/
Bikobi
FiXik, dzięki za pomoc. Nie odpowiadałem, póki nie wykorzystywałem wszystkich możliwości. Fix wywala masę błędów, ale nie tworzy tabel, nie pomógł.

Próbowałem wszystkiego, co możliwe, od chmodów, reinstalu, reuploadu po import i eksport innej bazy. Utworzyłem mianowicie nową czystą stronę na nazwa.pl, z nową bazą danych. Wszystko default. I to samo, ten same błędy. Udało mi się jedynie to, że mod utworzył 10 tabel, umożliwia działanie, ale to wciąż sytuacja niepełna i nie mogę ryzykować czasochłonnego importu downloadu. Wciąż wywala mi błędy, które wskazują na brak tabel
pdp_new_files i pdp_dir_files - i nijak ich utworzyć. Przeszukałem internet i nikt dotąd nie miał takiego problemu. Nie wiem nawet, ile ma być tych cholernych tabel wszystkich. Czemu nawet na czystej stronie mam to samo? Każda rada mi się przyda.

Prosiłbym też chociaż, by ktoś na czysto wgrał takiego moda i wyeksportowane ze swojej bazy tabele moda przesłał mi. Na ich podstawie, omijając niejako problem, ruszyłbym z pełnosprawnym downloadem. Bo sam ręcznie takich tabel utworzyć nie potrafię.


Jest jeszcze coś dziwnego. Wgrywam inne mody i one też nie dodają swoich tabel do bazy, a przecież takie mody jak Games_eXtreme_Warstats czy Event_Calendar tworzą chyba tabele. Nie mam już pomysłu.
 
FiXik
Dobra ... mój błąd ... pomieszałem parę rzeczy w pliku ... ale żeby ominąć problem z SQL (bo zauważyłem, że na niektórych starszych wersjach nie działa ten rodzaj tworzenia tabel) zrób tak ... zainstaluj oryginalną wtyczkę tak jak była ... a do utworzenia tabel ponizszy kod wstaw do dodatkowej strony i wykonaj podglad (nie zapisuj!):
Pobierz kod źródłowy  Rozwiń Kod źródłowy PHP

Będziesz miał tabele w/g wytycznych tego panelu ... Co dalej to już do ciebie należy :)

//długie kody dajemy w chili - chemix
Edytowane przez Chemikpil dnia 08.03.2009 13:40:30
 
http://www.zainwestujwemnie.eu/
Bikobi
FiXik napisał/a:Będziesz miał tabele w/g wytycznych tego panelu ... Co dalej to już do ciebie należy Smile
Dzięki! Smile Pomogło, wiedziałem co dalej, download ruszył. Wink

I choć problem połowicznie rozwiązałem, to nadal chciałbym poznać przyczynę, czemu mod sam tabel nie tworzy. Bo nawet na innych hostach mam to samo (stąd moja wcześniejsza prośba o tabele), tworzy tylko 10 tabel i dalej nie idzie. Co to za błąd?
 
FiXik
Powiem tak ... Ja mam problem na jednym serwie z instalacją czegokolwiek, nie tworzy żadnych tabel. Przyczyna, pytać trzeba administratora co jest po blokowane na jego serwie, że nie działa. Mam na swoim jednym kompie serwer zainstalowany i też część nie chodzi tak jak powinna, ale tu mam za to za stare oprogramowanie i do póki się nie wywali to nie będę zmieniał (brak czasu). Wniosek - przyczyna może być po stronie serwera, na którym jest obsadzona strona. Ale zawsze jakoś trzeba sobie radzić.
 
http://www.zainwestujwemnie.eu/
Bikobi
Dzięki, to sporo wyjaśnia. Rozumiem jeszcze problemy na darmowych serwisach (CBA, yoyo), ale na płatnym nazwa.pl - tu porozmawiam z nimi. Smile
 
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl