ForumCała strona

Nawigacja

Aktualnie online

Gości online: 15

Użytkowników online: 0

Łącznie użytkowników: 25,386
Najnowszy użytkownik: Hisfatt

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

MajsterBieda
25.02.2024 00:12:42
Ponad 20 lat .... tosz to sioook panie.... Grin

Zbigniew@
24.02.2024 22:05:41
Jeszcze tylko, pozostało, napisać artykuł i będzie gotowe. Za jakieś dwa dni.

Zbigniew@
24.02.2024 22:03:43
A ja wstawię auto reklamę. Zrobiłem pierwszy generator paneli na stronę główna, dla v9.

JazOOn
24.02.2024 20:32:31
a już na pewno mamuty

JazOOn
24.02.2024 20:31:59
Albo dinozaury

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Polecamy hosting SferaHost.pl

Nawigacja

Instalacja WampServer - serwera WWW na Windows

Napisane przez Gander dnia 20 lutego 2009 11:50 · 1 komentarz · 70422 czytań · Drukuj · Facebook · Wykop

Streszczenie:

Opis instalacji serwera WampServer w środowisku Windows.

Spis treści

  1. Opis
  2. Instalacja
  3. Konfiguracja
  4. Poprawki

Poprawki

Wymuszenie kodowania bazy danych

Faktem jest że szwedzkie kodowanie nie służy naszym polskim znakom diakrytycznym, a niestety baza domyślnie jest kodowana w latin1_swedish_ci. Jedyny znany mi i działający sposób zmiany kodowania całej bazy to wymuszenie kodowania za pomocą niżej opisanej modyfikacji.

  1. W menu WampServer-a kliknij MySQL > my.ini
  2. W sekcji [wampmysqld] dodaj kod zaznaczony poniżej na zielono:
    [wampmysqld]
    
    port		= 3306
    
    socket		= /tmp/mysql.sock
    
    skip-locking
    
    key_buffer = 16M
    
    max_allowed_packet = 1M
    
    ...
    
    datadir=c:/wamp/bin/mysql/mysql5.1.30/data
    
    
    
    character-set-server=latin2
    
    collation-server=latin2_general_ci
    
    skip-character-set-client-handshake
  3. Zapisz plik i zrestartuj serwer MySQL.

Skrypt tworzący aliasy

Skrypt tworzenia aliasów zawiera drobny błąd, przez który niektóre aliasy źle wpisane w przeglądarce wyświetlają błąd 403 lub 404. Poniżej przedstawiam kroki jak to poprawić?

  1. Otwórz do edycji plik c:\wamp\scripts\addAlias.php
  2. W linii 115 znajdziesz linijkę, taką jak poniżej: $newConfFileContents = 'Alias /'.$newAliasDir.'/ "'.$newAliasDest.'"
  3. Usuń slash zaznaczony na czerwono.
  4. Zapisz plik.

Komentarze

#1 | anette dnia 10 lipca 2009 14:01
Ha! Już wiem! Doszłam samodzielnie <duma> ;-D

Dodaj komentarz

Zaloguj się, aby móc dodać komentarz.

Oceny

Tylko zarejestrowani użytkownicy mogą oceniać zawartość strony
Zaloguj się lub zarejestruj, żeby móc zagłosować.

Brak ocen. Może czas dodać swoją?
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl