ForumCała strona

Nawigacja

Aktualnie online

Gości online: 9

Użytkowników online: 0

Łącznie użytkowników: 25,354
Najnowszy użytkownik: CYGAN

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

bubello
10.06.2021 08:52:49
Pewnie ze tak

JazOOn
07.06.2021 22:33:01
Ktoś tu jeszcze żyje?

hoopak
11.05.2021 03:20:12
Buuuu!

jantom
29.04.2021 21:03:32
Wszystkiego najlepszego Przemku Smile

MajsterBieda
23.04.2021 01:38:02
Cool

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Zobacz temat

Polski Oficjalny Support PHP-Fusion » Podstawowe zagadnienia związane z PHP-Fusion » Przedszkole
 Drukuj temat
Błąd w galerii nie zapisuje danych zdjęcia
popell
Witam, mam problem CHMOD w pliku settings_photo.php mam na 777 wszystkie inne (oczywiście które muszą być) też mają 777 a mimo to gdy wchodzę w PA --->zarządzanie stroną--->Ustawienia zdjęć i tam wpiszę jakieś dane zdjęcia miniaturki itd. nie zapisuje mi ich. Czym to może być spowodowane ? Dodam jeszcze że aktualizowałem stronę stopniowo tj. 6.0.1 6.0.2 itd. wszystko przebiegło ok.


PW od moderatora:
  1. Zmiana nazwy tematu - ICEK 29.04 - 16:23
 
Pieka
Pliki maja miec CHMOD 644, a katalogi 755, oczywiscie poza tymi, ktore musza miec 777.
Do tych ostatnich naleza np. images, photoalbum, submissions oraz katalogi albumow zdjec, o ile nie ma sie na serwerze wlaczonego trybu bezpiecznego (safe_mode On), poniewaz w przypadku jego aktywnosci, galeria nie tworzy katalogow albumow, tylko pakuje zdjecie do jednego wspolnego (photoalbum).

Jesli przechodziles z v6.00.2xx do najwyzszej, czyli v6.01.xx, to po drodze bylo wymagane konwertowanie galerii. Wykonales?

Na forum jest wszystko opisane, wystarczy chciec cos znalezc..
Jestem jaki jestem Smile
 
www.php-fusion.pl
popell
Szukam coś o tym przekonwertowaniu i nie znajduję, nie wiem może jakiś temat przeoczyłem, jak tę galerię przekonwertować ? (ona jest pusta w tej chwili) ściągnąłem tą wtyczkę konwerter galerii i ale wyskakuje mi błąd po wejściu w nią
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Edytowane przez Pieka dnia 29.04.2008 22:53:50
 
Pieka
Zainstaluj pierwsze konwerter, a dopiero pozniej konwertuj. To wtyczka jak kazda inna, wiec wymaga instalacji.
Jestem jaki jestem Smile
 
www.php-fusion.pl
popell
No to zainstalowałem konwerter i mi ten błąd co wyżej pisałem wyskakuje.
Edytowane przez Pieka dnia 29.04.2008 23:21:13
 
Spoczywaj w pokoju... wlodekp
W sytuacji, kiedy miałeś starą galerię, ale ona, była pusta, bo jej nie wykorzystywałeś (nie było zdjęć)
Tak wnioskuję z Twoich postów powyżej.
Jednak tylko, jeśli rzeczywiście tak jest.
Strukturę galerii(bazę) można utworzyć przez wklejenie części kodu, pliku setup.php po między znaczniki <?php ?> w nową stronę informacyjną z poziomu PA i wykonanie jej podglądu bez zapisu.
Można użyć kodu z pliku setup.php wersji, którą chcemy mieć na stronie czyli ostatniej 6.01.15:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Jeszcze raz podkreślam do użycia wyłącznie, jeśli galeria była pusta, bo wszystkie stare dane zostaną usunięte
 
wlodekp.europa.pl
popell
No ok, zrobilłem ale dalej nic, mi nie zapisuje danych zadnych w pliku settings_photo.php gdy coś chce wpisać w PA --- Zarządzanie stroną --- Ustawienia Galerii wpisuję i daję zapisz i mi czyści ten blankiet który tam jest.
Edytowane przez Pieka dnia 02.05.2008 11:23:55
 
Spoczywaj w pokoju... wlodekp
Ta operacja zmieniła jedynie strukturę galerii, na taką by pozwalała dodawać i wyświetlać fotki.
Cały fusion opiera się na bazie danych i plikach, żeby działał te rzeczy muszą pochodzić idealnie z tej samej wersji fusion. Dotyczy to także pliku settings_photo.php i tabeli bazy settings i w tej chwili trudno powiedzieć, które z nich z jakiej masz wersji, bo musi tu być niezgodność baza plik. Opisana przeze mnie wyżej modyfikacja nie ma bezpośredniego oddziaływania na plik settings_photo.php ustawień galerii on czyta dane nie z tabel galerii, a ustawień settings i tu należy już być bardzo ostrożnym, gdyż jest to podstawowa tabela do startu systemu fusion, nie może być pusta, więc sposób jak z galerią odpada, na jej modyfikację-bo strona nie wstanie przy błędzie.
Jeszcze jednym elementem, który ma tu znaczenie jest plik locale/admin/settings.php seria v6.01 ma inne pola jak 6.0.xxx i możesz błędnie widzieć przyciski.
Tak więc potrzebna jest w tej chwili struktura Twojej tabeli settings, bez danych, pokaż scrina, albo załącz plik kopii bazy tylko tej tabeli, samej struktury.
Przy założeniu, że opisywane pliki:
administration/settings_photo.php
locale/admin/settings.php
pochodzą w 100% z nowej serii 6.0.1
a 100% = nie nadpisywanie a usunięcie i wgranie nowego,
można dopiero zająć się tabelą bazy i ustalić co i jak zmodyfikować.
EDYCJA
Czytając teraz dokładnie o braku tabeli i błędach, mniemam, że Ty robiąc upgrade nie uczyniłeś tego z PA i nie zmodyfikowałeś tabel przez uruchomienie pliku administration/upgrade.php gdzie np ta tabela jej modyfikacja ma taki kod:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Edytowane przez wlodekp dnia 02.05.2008 08:17:44
 
wlodekp.europa.pl
popell
Dobra dzięki teraz inny problem... mianowicie wgrałm wtyczkę watermark i ok, album zrobię nawet "dodam do niego zdjęcia" ale wychodzę w album i nie ma miniaturek jest wzamian nazwa pliku - zdjęcia, wchodzę w to zdjęcie i dalej też jest praktycznie to samo tzn. pokazuje mi nazwę pliku- zdjęcia ale nie pokazuje zdjęcia. Wie ktos jak to zrobić ?
Edytowane przez Milka dnia 02.05.2008 22:55:52
 
bartek124
Zobacz czy w folderze images/photoalbum są jakieś pliki/foldery.
userbar_bartek124_net.png mw.gif Nie pomagam na komunikatorach oraz PW!
 
www.bartek124.net
popell
Nie ma nic...
Edytowane przez Milka dnia 03.05.2008 21:50:40
 
Spoczywaj w pokoju... wlodekp
A jak dodajesz zdjęcie z PA to jest jego miniaturka w PA, sprawdziłeś chmody, obecność biblioteki gd na Twoim serwerze, avatara możesz dodać?
Proszę podać adres strony i nazwa hostingodawcy co to za serwer?
Same niewiadome i jak Ci pomóc?
 
wlodekp.europa.pl
popell
W PA również po dodaniu zdjęcia nie ma miniaturki co dziwne wg. mnie po stworzeniu nowego albumu miniaturka tego albumu jest ale zdjęcia w nim nie.
CHMODY tez zdają się być dobre, bibliotekę gd mam, avatar mogę dodać.

Adres strony: www.victoriaswieb....strefa.pl
Serwer jest ze strefa.pl
P.S. W galerii jest przykładowy album i fotka

halo wie ktoś o co może chodzić ?
Edytowane przez popell dnia 07.05.2008 18:54:22
 
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl