ForumCała strona

Nawigacja

Aktualnie online

Gości online: 3

Użytkowników online: 0

Łącznie użytkowników: 25,349
Najnowszy użytkownik: BlackRosse

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

MajsterBieda
28.02.2021 00:54:28
No wesołe wesołe! Grin Grin

hoopak
24.02.2021 19:43:03
Wesołe jest życie staruszka Grin

piterus
14.02.2021 22:31:41
@JazOOn Wcale nie był prostszy... Po prostu byliśmy bardziej plastyczni... Teraz reumatyzm przeszkadza... Pfft

JazOOn
14.02.2021 21:11:09
Kiedyś internet był prostszy...

piterus
28.01.2021 17:17:39
Trzeba... Niech zwierzaki przez chwile mają trochę wytchnienia... Pfft

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Zobacz temat

 Drukuj temat
PHP-Fusion na wersji PHP 7.2
Apis
Jeśli wgrasz na serwer i zainstalujesz wtyczki po zaimportowaniu bazy - stracisz w bazie dane pochodzące z tych wtyczek (będą puste tabele) i ponownie trzeba będzie wgrywać bazę. Po co robić to dwa razy?
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
http://www.zegluga-rzeczna.pl
xys
Apis napisał(a):

Jeśli wgrasz na serwer i zainstalujesz wtyczki po zaimportowaniu bazy - stracisz w bazie dane pochodzące z tych wtyczek (będą puste tabele) i ponownie trzeba będzie wgrywać bazę. Po co robić to dwa razy?


Więc, jeśli dobrze rozumiem twój wpis, zrobiłeś to w ten sposób, że zainstalowałeś czyste v7 php7. Zainstalowałeś wtyczki, nie usunąłeś tej czystej bazy tylko na jej miejsce wgrałeś bazę używalną i w ten sposób nadpisały się tabele bazy? Proszę, wyjaśnij mi to jaśniej. Przecież w skopiowanej bazie danych będą tabele z zapisem danych z różnych wtyczek, to nie rozumiem, po co te wtyczki instalować na nowo zainstalowanej stronie.

Apis napisał(a):

Bardzo dobra robota Grin . Zainstalowałem wersję dla php 7, dodałem i uruchomiłem użytkowane wtyczki a potem zaimportowałem bazę z użytkowanej obecnie v. 7.02.07. Działa. Nieco okrojone z obrazków i funkcji testowe demo: http://www.zeglug...page_id=28
 
krystian1988
Na szybkie myślenie... Czysta instalka, wgranie tego co miał na poprzednim i przywrócenie bazy.. To masz na zasadzie przenosin na inny serwer czyli nic trudnego i najlepsze wyjście przy update Smile
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
Apis
xys napisał(a):
Proszę, wyjaśnij mi to jaśniej. Przecież w skopiowanej bazie danych będą tabele z zapisem danych z różnych wtyczek, to nie rozumiem, po co te wtyczki instalować na nowo zainstalowanej stronie.

Gdy najpierw wgram bazę z poprzedniej wersji - owszem, będą tam tabele wtyczek i dane pochodzące z tych wtyczek (mam na przykład wtyczkę płatnych ogłoszeń). Jeśli jednak dopiero po wgraniu bazy zainstaluję w czystej instalacji te wtyczki - w bazie zostaną te tabele wyczyszczone z danych (nadpisane). Stracę więc dla przykładu wszystkie dodane ostatnio (i jeszcze ważne) ogłoszenia. Będę musiał ponownie wgrać te dane. Po co więc utrudniać sobie zadanie?

A więc:

1. Instaluję czystą wersję pod PHP7. Podczas instalacji (dla własnej wygody) wpisuję prefiksy baz i cookies takie same jak w używanej dotychczas wersji (patrz config.php).
2. Wgrywam i instaluję używane przeze mnie wcześniej wtyczki (przy okazji sprawdzam, czy poprawnie się instalują, co wcale nie jest takie oczywiste - krystian1988 coś o tym wie Grin ).
3. Jeśli wtyczki zainstalują się poprawnie - importuję swoją poprzednią bazę.

Mam jeszcze drugą wersję zrobienia update - dużo prostszą (bez instalacji), ale nie znaczy to, że jeśli zadziałała u mnie - zadziała u kogoś podobnie.

1. Stare pliki tworzące stronę pakuję na serwerze (w tym samym folderze głównym) do jednego podkatalogu (np. "_old" ).
2. Wgrywam do katalogu głównego nowe pliki PHP-Fusion v7.xx.xx dostosowane do wersji PHP7.
3. Przerzucam z katalogu "_old" istotne pliki (głównie np. całe katalogi "images", "Themes" ) oraz pliki wtyczek z powrotem do katalogu głównego w odpowiednie miejsca.
4. Podpinam to wszystko pod istniejącą bazę poprzednim plikiem "config.php" dodając w nim jedną linię - w moim przypadku $db_driver = "mysqli";

Nie muszę w ogóle eksportować i importować bazy ani instalować wtyczek. Muszę jednak mieć pewność, że wtyczki są kompatybilne z nową wersją.
Edytowane przez Apis dnia 23.12.2018 13:29:01
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
http://www.zegluga-rzeczna.pl
sq8mxs
Jedno małe pytanie. Zrobiłem, działa jest ok do momentu wgrania własnych wtyczek. Chodzi o kodowanie znaków. Cała strona z paczki ma polskie znaki. Z moich wtyczek jedna pokazuje znak zapytania w polskiej czcionce a druga połowicznie działa tzn to co jest w bazie pokazuje z polskimi znakami, to co jest w pliku php już ze znakami zapytania. Bazę danych zweryfikowałem, kodowanie ustawione na utf-8 nawet w poszczególnych tabelach. Czy gdzieś w tej paczce może dopisuje się wtyczki, albo we wtyczkach w plikach trzeba coś dopisać ?
 
www.egzaminkf.pl
Apis
Zauwazyłem, że przy wcześniejszych "czystych" instalacjach PHP-Fusion wybierając język polski i kodowanie UTF-8 wpisy w tabelach bazy posiadały mimo wszystko kodowanie latin-2 (przeglądając bazę widać było "polskie" literki). Teraz po zmianie kodowania w pojedynczych tabelach na utf-8 w PHP-MyAdmin już nie widać "polskich" liter choc na stronie wyświetlają sie poprawnie.

Przekonwertuj więc tabele wtyczek na UTF-8 (np. Gżegżółką) i prześlij je na serwer. Oczywiście zrób sobie kopie tabel. Powinno zadziałać bo miałem podobny problem.
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
http://www.zegluga-rzeczna.pl
kamildnb
Bardzo dobra robota Krystian88, ja się trochę spoźniłem na Twoja wersję i sam się musiałem męczyć, ale wersja v7.02.07 jest na prawdę tego warta! u mnie będzie bazować bardzo długo, Polecam!!! Smile
 
sq8mxs

Przekonwertuj więc tabele wtyczek na UTF-8 (np. Gżegżółką) i prześlij je na serwer. Oczywiście zrób sobie kopie tabel. Powinno zadziałać bo miałem podobny problem.


sorry że dopiero teraz,ale czasu nie było wrócić do tematu. Rewelacja, potraktowałem programem pliki wtyczek i wszystko wróciło do normy, jutro zajmę się bazą danych.
Wielkie dzięki.
 
www.egzaminkf.pl
xys
@krystian1988

Nie działa wbudowana recaptcha. Podczas rejestracji wyświetla się:

images90.fotosik.pl/182/ef1ad6247effe848.png

Masz jakiś pomysł, jak ten błąd rozwiązać?
 
krystian1988
Recaptcha v2 klucze, nie v3 Wink
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
bubello
Miałem podobny błąd.
Nie pamiętam w którym pliku ale zmieniałem kod Recaptcha
Smile
 
http://karix.pl
Amarena
W razie problemów z UTF8 łapcie setup http://wklejto.pl...
 
Apis
Wersja działa w zasadzie bez problemów na PHP 7.4. Właśnie podpiąłem swój serwis pod ten numerek. Trzeba się rozstać z niektórymi starszymi wtyczkami czy modami (np. rss, news_archiv.php) lub nad nimi popracować.
Pozdrawiam. Pomogłem? Kliknij "Pomógł" Wink
---
Żegluga śródlądowa wczoraj, dziś, jutro
 
http://www.zegluga-rzeczna.pl
krystian1988
Starsze mody też działają, przeważnie trzeba po prostu zamienić zapytanie czy też funkcję Smile sam testuję na 7.4 i dwa pliki jak na razie miałem do poprawy. Smile
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
qwertyuiop
Udało mi się przenieść v7 na PHP7 wg instrukcji w tym temacie.
Jednak z jedną wtyczką nie wiem co zrobić, a mianowicie z awEventCalendar 0.8.4. Oczywiście da się usuwać wydarzenia z kalendarza, ale edytować i dodawać już nie.

PDOException: SQLSTATE[22007]: Invalid datetime format: 1292 Incorrect date value: '0000-00-00' for column 'ev_end' at row 1


Ściągnąłem z Support'u co.uk wtyczkę, kalendarza niby przerobioną pod PHP7, ale niestety nie działa poprawnie i nie jest tak fajna jak moja stara Wink Czy ktoś mógłby mi pomóc i poprawić awEventCalendar, aby działał pod PHP7?

Oczywiście jako dojrzały użytkownik odpowiednio się odwdzięczę Smile
 
adi
Witam ja nie robiłem update tylko czystą instalację, ale mam dziwne zjawisko, mianowicie zapisuje mi jakiś dziwny adres IP
Pobierz kod źródłowy  Rozwiń Kod źródłowy

ja jako admin dodałem 5 osób i jak ja edytuje to tam jest właśnie ten dziwny kod, dałem admina innej osobie i jak ona edytuje to też daje ten dziwny kod, ale jak już osoba bez admina edytuje to daje normalne jej IP.

Wie ktoś o co tu chodzi, albo ja coś znowu zepsułem i to tylko tak u mnie?.

Pozdrawiam i dziękuje z góry za sugestie.
Tylko dwie rzeczy są nieskończone: wszechświat oraz ludzka głupota, choć nie jestem pewien co do tej pierwszej.

Albert Einstein

Nie posiadam GG FB czy tam jeszcze czegoś innego jak co PW
 
slaskimix.eu
jantom
Łapie Tobie IPv6, zamiast klasycznego IPv4.
No i wystarczy tego dobrego... ...bo prorok jest tylko jeden...
 
http://jantom.info
adi
Witam tak też wyczytałem gdzieś w necie, ale jak to naprawić oto jest pytanie Wink
Czy to w ustawieniach serwera, ale chyba nie bo jak był zwykły fusion to było normalne ip
edit//
Jednak to chyba wina serwera bo na OVH jest wszystko ok.
Pozdro all
Edytowane przez adi dnia 30.01.2021 15:02:03
Tylko dwie rzeczy są nieskończone: wszechświat oraz ludzka głupota, choć nie jestem pewien co do tej pierwszej.

Albert Einstein

Nie posiadam GG FB czy tam jeszcze czegoś innego jak co PW
 
slaskimix.eu
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl