ForumCała strona

Nawigacja

Aktualnie online

Gości online: 10

Użytkowników online: 0

Łącznie użytkowników: 25,359
Najnowszy użytkownik: kdomi

Logowanie

Nazwa użytkownika

Hasło



Zarejestruj się

Odzyskaj hasło

Shoutbox

Musisz zalogować się, aby móc dodać wiadomość.

DJPromo
05.12.2021 13:37:54
Siemka Smile co tam słychać

JazOOn
08.11.2021 23:22:32
Widzisz a ja poszedłem w logistyke i transport Grin

Gander
07.11.2021 16:29:48
Aż się łezka w oku kręci. Wpadłem sprawdzić, od kiedy robię w PHP (rok założenia konta) Wink

JazOOn
04.11.2021 22:43:11
No ale Pieka to już tu z 5 miesięcy nie był

JazOOn
21.10.2021 22:40:48
Tak ,to ten sam JazOOn Grin

Pobierz nową wersję
Pobierz podręcznik
Zobacz inne oficjalne Supporty
Statystyki supportu
PHP-Fuson PL na Facebooku

RSS

Zobacz temat

 Drukuj temat
Pola Profilu na Forum (Userfelder Im Forum)
bogdan
Siemanko. :)
Fajna wtyczka znaleziona na stronie -> Joetho

Nazwa: Userfield on forum
Wersja: 1.0
Autor: © Dennis Vorpahl (hajabamba, Starunited) i PHP-Fusion4You
Strona/wsparcie: J/W
Kompatybilność PHP-Fusion: v7.02.05
Licencja: GNU Affero GPL v3

Opis:
Wtyczka pozwalająca na wyświetlanie wybranych przez Administrację Pól Profilu Użytkownika na Forum.

Wygląd na Forum:
img.liczniki.org/20120923/bogdan_2012_09_22_19h35m50s_002-1348411223.png

Wygląd PA wtyczki:
img.liczniki.org/20120923/bogdan_2012_09_22_19h54m16s_003-1348411223.png

Instalacja:
UWAGA.
Jeśli był modyfikowany plik - "forum/viewthread.php", nie nadpisuj go tym z paczki, tylko otwórz w edytorze plików i poszukaj linii - 281 282:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Pod nią dodaj:
Pobierz kod źródłowy  Rozwiń Kod źródłowy


Zapisz i wyśli na serwer.


Przy nie modyfikowanym pliku - "forum/viewthread.php" - wrzuć wszystkie pliki i foldery do odpowiednich katalogów na swoim serwerze.

Dalsza instalacja dotyczy obu wariantów.
Przejdź do PA -> zarządzanie stroną -> wtyczki, wybierz z rozwijanej listy - "Userfelder Im Forum" i zainstaluj.
Następnie przejdź do PA -> wtyczki -> Pola Profilu na Forum i ustaw wg. uznania.

Nie wszystkie Pola Profilu ustawiona na Forum będą spełniać swoje zadanie, bo np. "Podpis", będzie się mijał z celem, a po za tym nie wyświetli grafik dodanych w podpisie.
Sugeruję dodawanie pól, które mają jakiś cel.

Musiałem trochę podłubać w pliku, bo z oryginalnej paczki po instalacji pokazywał się komunikat o zdublowaniu nazwy kolumny "field_forum".

Dodałem polskie pliki językowe w obu kodowaniach, plik RedMe_pl, polskie tłumaczenie licencji i screeny.
Wszystko w folderze "Pl_info".

Dodano do MODs

EDIT:
Paczka poprawiona.
Prawdopodobnie nie tą dodałem, którą miałem dodać. :|
bogdan dodał/a następującą plik:
v7_userfelder_im_forum_v1-0_pl.zip [117.82kB / 570 Pobrane]

Edytowane przez bogdan dnia 27.11.2013 21:30:13
Nie szukaj Szczęścia, lecz dawaj Je innym, a wtedy samo do Ciebie przyjdzie.
Nie ma mnie na GG. Pfft
 
dysko-patia.eu
Bogver
Witam. Mam problem. Po wrzuceniu tej wtyczki na swoją stronę i jej instalacji -> wszystko przebiega prawidłowo.

Wchodzę na PA->Wtyczki-> error
a mianowicie pokazuje mi się taka właściwość :
www.iv.pl/images/64995953065105867914.png
czyli nie mogę ustawić co ma wyświetlać pod avatarem na forum.

Czy ktoś mógłby pomóc mi w poprawie tego panelu ?

Ponadto będąc w samym forum pod avaterem usera pokazuje takie info:
www.iv.pl/images/19726418168188803217.png
 
www.akwariowo.eu
piotrek199214
Nie zainstalowało poprawnie wtyczki, tzn nie dodało tabeli i pól do bazy danych. Pozdrawiam
Pomogłem Ci? Wystarczy podziękować i oznaczyć post jako pomocny pomogl[1]_1.png
Tanie tworzenie wtyczek, masz problem napisz.
 
www.piocom.eu
Bogver
Czyli ręcznie muszę dodać pola do bazy danych i powinno zadziałać ?
Czy może błąd powoduje iż moja baza danych ma inną nazwę ?
zamiast DB_USER_FIELDS czy bym musiał mieć akwariowo_user_fields ?
Jeśli tak, to muszę edytować pliki te dodane do wtyczki ?
Edytowane przez Bogver dnia 27.02.2013 06:50:27
 
www.akwariowo.eu
krystian1988
Wgraj jeszcze raz pliki tam gdzie powinny być. Baza się nie zmienia tylko prefix, czyli przykładowo przy instalacji PHP-Fusion masz prefix tabeli: fusion4567s_ i pod to podpisuje tabele czyli np. fusion4567s_USER_FIELDS. Każde zapytanie przez DB to prefix a reszta to wybór tabeli. Sprawdź czy dobrze wgrałeś wszystkie pliki owej wtyczki.
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
Bogver
Wgrane są prawidłowo do odpowiednich katalogów. Mod Bogdan sprawdzi wieczorem, jak wróci do domu. Możliwe że w paczce brakuje jednego plika.
 
www.akwariowo.eu
krystian1988
Nie brakuje żadnego pliku sprawdziłem sam. Wszystko jest ok.
Podmień forum na ten z paczki i zobacz.
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
Bogver
Niestety. Nawet pobrałem i rozpakowałem ponownie paczkę.
Jest tak samo. Myślałem nawet o tym, co Pieka pisał o tym TYPE i ENGINE.
Ale tego nie znalazłem Sad

Może ktoś ma poradę jak zrobić by zadziałało ?
 
www.akwariowo.eu
bogdan
Cześć.
Pisałem do jednego ze współautorów, próbując się zarejestrować na jego stronie (po akceptacji), żeby móc pobrać wtyczkę porównać, ale drugi dzień bez echa.
Z tego co widzę, to strona jest tylko dla użytkowników trzech państw.
Drugi współautor, niestety zmarł i jego strona już nie funkcjonuje.
Może Kris by kuknął, co mogło się w nie podziać, skoro hulała i przestała.
@Kris, a Ty ją sprawdzałeś i działa?
Nie szukaj Szczęścia, lecz dawaj Je innym, a wtedy samo do Ciebie przyjdzie.
Nie ma mnie na GG. Pfft
 
dysko-patia.eu
krystian1988
W dodatkowych stronach wklej zapytanie:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

daj podgląd.
Demo: http://krismods-f...hread_id=1
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
Bogver
Jesteś genialny. Działa. Serdeczne wielkie dzięki :)
Po wrzuceniu kodu i kliknięciu na podgląd w dodatkowych stronach pojawił mi się tekst ->
Pobierz kod źródłowy  Rozwiń Kod źródłowy


Wszedłem na PA->Wtyczki->userfelder i działa w 100%.
 
www.akwariowo.eu
bogdan
Wszystko ok (koło Wink ).Smile
Tylko co się porobiło, że wcięło, jak działało, polecenie tworzenia tabel?Shock Grin
Kris, przeleć tą paczkę, bo już mi nerw siadł, pewnie gdzieś banalny błąd robię.
Jak dodaję do pliku polecenie, to dostaję komunikat o dublowaniu tabel.
Chyba za bardzo się zakopałem. Grin
Nie szukaj Szczęścia, lecz dawaj Je innym, a wtedy samo do Ciebie przyjdzie.
Nie ma mnie na GG. Pfft
 
dysko-patia.eu
krystian1988
bogdan, ty już tą tabelę posiadasz przez inną modyfikację. Musiałbyś przejrzeć co tworzy pole. Też myślałem że jest poprawne, lecz zapomniałem też że już sam wcześniej robiłem poprzez zapytanie do bazy. Nowo zainstalowana strona wyświetliła komunikat o błędzie więc po swoim update zamieściłem kod odpowiedzialny za w/w błąd.
BRAK STOPKI = BRAK POMOCY NA SUPPORCIE.PRZECZYTAJ:
Regulamin Supportu Nie pomagam na PW!!!
 
bogdan
No właśnie na czystej stronie zainstalowałem z plikiem po modyfikacja, z zapytaniem do bazy i wyświetliło "dubel".
Jak z plikami z paczki, plus Twój kod jest ok.
Nie szukaj Szczęścia, lecz dawaj Je innym, a wtedy samo do Ciebie przyjdzie.
Nie ma mnie na GG. Pfft
 
dysko-patia.eu
Mikesz
Witam
Na wstępie chciałem przeprociś za odkopanie tematu. Mimo zastosowanie w/w sposobów uruchomienia tej wtyczki to niestety ale u mnie ona nie działa. Dokładnie pokazuje następujący błędy:
1. w PA wtyczki > Pola Profilu na Forum
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Screen: iv.pl/images/92471724234344449811.png

2. W wątku na forum
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Screen: iv.pl/images/92961400889168507610.png

Wersja PHP-Fusion: 7.02.07
 
http://ticoteam.com.pl
lem
@Bogdan

Używając tego kodu

Pobierz kod źródłowy  Rozwiń Kod źródłowy


Można dodać wyświetlanie zawartości własnego User_Fields z pliku user_fields który jest w includes?
Edytowane przez lem dnia 27.11.2013 12:35:57
 
bogdan
Odpuściłem kopanie po tej wtyczce.
Kombinowałem i jak nie z jednej strony kicha wychodziła, to z drugiej.
Autora wtyczki już nie ma, ale może jak Krystian kuknie na Forum, to rzuci jakimś pomysłem.
Nie szukaj Szczęścia, lecz dawaj Je innym, a wtedy samo do Ciebie przyjdzie.
Nie ma mnie na GG. Pfft
 
dysko-patia.eu
Pieka
Tak między nami żołnierzami, co ma dodawać to brakujące pole do bazy? W pliku infusion.php nie ma żadnej komendy... Jesteście pewni, że to wszystkie pliki/opisy?

Edit: W końcu znalazłem czas, żeby dopisać Smile Chopy! Brakuje pola profilu i stad brak go w bazie. Coś Ci Boguś chochliki napsociły w paczce Wink
Edytowane przez Pieka dnia 27.11.2013 18:39:42
Jestem jaki jestem Smile
 
www.php-fusion.pl
bogdan
:D
Przemek, bo to jest trochę pomotane, zmieniałem paczkę i w końcu nie pamiętam na jakim etapie ją dodałem. :D
Na tą chwilą, wygląda to tak - jeśli w pliku infusion.php dodam:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

instaluje wtyczkę, ale w PA - wtyczki wyskakuje:
Pobierz kod źródłowy  Rozwiń Kod źródłowy

Dopiero odinstalowanie, usunięcie folderu wtyczki, usunięcie w/w linii z infusion.php i ponowne wgranie i instalacja usuwa błąd z PA.
Jakiś pomysł, bo ja jestem poza zasięgiem tego, bo mi się zwoje wyprostowały. :D
Chyba nie zamotałem bardzo. :D
Nie szukaj Szczęścia, lecz dawaj Je innym, a wtedy samo do Ciebie przyjdzie.
Nie ma mnie na GG. Pfft
 
dysko-patia.eu
Pieka
Moim zdaniem brakuje pola profilu o podanej nazwie pola w bazie. Zapewne gdzieś je zapodziałeś Smile
Jestem jaki jestem Smile
 
www.php-fusion.pl
Przejdź do forum:
Created by Arox Copyright (C) 2004
Copyright (C) 2004 - 2018 Ekipa PHP-Fusion.pl